WordPress 2.5 and Top Commentators Widget matters

If you haven’t been reading your WordPress dashboard feeds, you’d be interested to know that WordPress 2.5 will be in stable release in a month’s time. I’ve been reading about how cool the next WP will be due to several capabilities usually only found in plugins to be integrated into WordPress itself, such as WP automatic updating, better tag management options, SEO-friendlier page titles, multimedia file management (not just images), multiple widget-enabled sidebars capabilities, and a few more improvements. More news about 2.5 can be found at BlogHerald.

Truthfully, although I’m always optimistic of every WP version updates working on my blog, I’m a little nervous of all those enhancements being made this time around and I really hope there aren’t too many bugs once I implement 2.5 in my box. I really don’t want to bother with sandboxing it, I’m just too lazy to do it ๐Ÿ˜› Seriously though, due to this I may have to put off releasing the newer version of Top Commentators Widget. Instead of releasing by the end of March, I’m moving it forward till April so that I have ample time familiarizing myself with the changes especially on the widgets and sidebar enhancements happening in 2.5. Also, I’m considering an attempt to modify Brian’s Threaded Comments to enable paging, something I’m eager to have in my comments section, particularly for the Top Commentators section which currently has 89 pingbacks and comments lying around.

I’ll stop my WP 2.5 and plugin rantings here until its release in March.

Spread the love
Posted on 7 March, 2008 under Discovering WordPress and tagged with

16 responses to “WordPress 2.5 and Top Commentators Widget matters”

  1. Nossa equipe no brasil tanmbem usa este tipo de sistema

    Obrigado

  2. Thanks for brining this to moy attention. I was going to update a few of my blogs to 2.3.3 but will hold off for this!

  3. Thanks for this information, I am gonna update my blog in a few minutes.

  4. Abas says:

    Hi, Webgrrl

    How are you?

    I have been upgrading my WP blogs whenever there are new upgrades available. No problems so far for me as I am not much of a hack here, hack there, kind of WP user. I guess I do have one of your widgets on my blogs. No, I just checked. I have recent comments plugins. I’ll take a look at yours now:)

    Abas
    iel2.aimvotal.com

  5. Si Philp says:

    Not sure if this post would interest you regarding the top commentators plugin?

    http://www.stuffbysarah.net/blog/2008/03/08/top-commentators-list-hijack

    Wouldn’t want to see a nast get on your site ๐Ÿ™‚

    Si

  6. So when is the next upgrade? Isn’t is safe to upgrade every time there is an upgrade available. I upgrade, if anything, to get rid of the notifications every time I sign in. I read somewhere that it is possible for hackers to easily gain control over your blog if it is not upgraded. IS that true?

  7. Thanks for the info, I am gonna update my Blogs…

  8. vincent says:

    Just waiting too for this release, by the way thanks for mentioning it. I rarely read my wordpress dashboard feed.

  9. raluca says:

    i hate to update!

  10. Kate B says:

    Definitely looking forward to 2.5, especially with some of the stuff they’ve shown with the Admin section (they just posted it here: http://wordpress.org/development/2008/03/25-sneak-peek/ )

    Love the Top Commentators plugin, so hopefully you’ll have it ready for the official 2.5 release! When is it supposed to be released, anyways?

  11. NSpeaks says:

    Your widget breaks in WordPress 2.5 with following error:

    Fatal error: Cannot redeclare ns_substr_ellipse() (previously declared in /home/navjot/public_html/submityourcontest/wp-content/plugins/top-commentators-widget/topcommentators_widget.php:26) in /home/navjot/public_html/submityourcontest/wp-content/plugins/top-commentators-widget/topcommentators_widget.php on line 26

    Widget shows in blog but can’t be edited via Widgets Options showing the above error.

  12. I’m getting the same error after upgrading to 2.5. Just like Nspeaks, widget shows on blog and works, but I’m unable to edit in Admin.

    I’m sure you’re already working hard on this. I look forward to an update.

    Keep up the good work.

    Kevin

  13. Lissy says:

    I fixed it. If you take everything out of the main widget_topcomm function and just list all the functions after, the error goes away. Visit my site and comment if you want me to send the code. It’s a little messy though and I changed a few things to fix a bug where if someone with the same name as someone else comments, it would sometimes pick the other person’s URL.

  14. I tried updating to WordPress 2.5 but some of the Plugins I have activated must haven’t been compatible and I ran in to all sorts of problems, so I backed-up to a 2.3 version for now. Didn’t spend too much time trying to find the break, but I guess I’ll have to get around to it sooner or later.

    Think I’ll check back here first when I ready to learn of any possible issues. Thanks!

  15. Eric says:

    For any of you who are getting the error above (“Cannot redeclare ns_substr_ellipse()”), make sure you’re not running the Show Top Commentators plugin as well. I had this issue the other way around (I had installed Top Commentators Widget and then tried to install the Show Top Commentators plugin, which gave the error message). I deactivated Top Commentators Widget and that fixed the issue.